0
Fixed

Ring of Shadows

AlpineHiker03 6 months ago in Graphics/Visual Performance • updated by Tyler Owen (Lead Developer) 2 weeks ago 10

On an Mac. Looking thru HUD, I have these ring of shadows. Some are rectangular, some are elliptical. It's as if some debris is circling above my head and the sun is casting the shadows about 6 feet in a ring. Doesn't affect performance. 

Also, at night, I see tiny white specular dots, like fireflies.


BTW, awesome concept and really enjoy what you have done so far. Looking forward to more updates!!



GOOD, I'M SATISFIED
Satisfaction mark by AlpineHiker03 2 weeks ago
Under review

Thanks. I'll have to take a look at this.

Here is a screen grab so you can see.


Is it only when the scanner is on? Also, when you say it's a ring, do you mean in a general circles around your point of view? These might be the invisible objects that create the scanner shapes. I haven't had a chance to test on Mac lately, but I will be checking on this soon.

With or without, it's there, except when in HAB. Small shadows like the two in pic above, line in an arc, so if I look left or right, it follows a circular path (only one path) . The shadows do follow the terrain contours when in motion, and "squish" as I look more forward, and a little "fatter" as I look towards my feet.


Thanks for the details. It might just be some strange shadow rendering difference on Mac that I hadn't encountered before. If anyone else on Mac can confirm that they are also experiencing this issue that would help me a lot.

This shot is facing forward, while the shot above is to my left, having moved only my view and not my feet.

Appreciate the quick reply. No big issue, only visual.

Started

Can anyone check if this is still in build 0.59.1? I have never experienced it on my mac I use for testing so I don't know if this has been fixed by updating the game engine.

Fixed

I have not had anyone report this same issue. It also may have been passively resolved by changes to the rendering pipeline while upgrading to a new version of Unity. If anyone can confirm that this issue still persists then I will reopen this topic.