+1
Under review

Mac build 0.5 unplayable due to performance issues

Thrantor 9 months ago in Graphics/Visual Performance • updated by Tyler Owen (Lead Developer) 6 months ago 9

I just got the most recent build off of Humble Bundle after the announcement today and I was excited to play. However, after downloading it, unzipping it and starting it. At beautiful, 1440x900(i think) it was unplayable. maybe 3 frames a second. After turn quality down to simple, it sped up to around 5 frames a second. I've got a somewhat newish macbook pro(Four Core I7) with a built in Nvidia GT 650M. But... it's just chugging away?


Is there a configuration that I'm not doing correctly? I'm hoping to play this game.

Under review

That does seem unusually slow. I have a 2013 Macbook Pro that I use for testing and I'm able to get a relatively stable 30 fps on Fastest graphics settings with Lighting Effects and SSAO/SSAA turned off. I know it's not fun to have to play on the lowest possible settings, but this game has never really targeted laptops as a system spec. Unfortunately, when it comes to Mac, laptops are much more common than desktops. If you are not able to get at least 30 fps with everything turned off/set to low, then perhaps there is something else going on that we would need to investigate.

I think I have more information. When I plugged in the laptop the performance got better. So, I'm wondering if the onboard non-Nvidia chip was the one originally running. However, even with the laptop plugged in I'm still getting pretty meh performance. Any suggestions? Or things I should look at? Is there a way to do a dxdiag equivalent and get that sent to you?

Thanks for the additional information. That certainly makes more sense. I appreciate that you are still unsatisfied with the performance on your Mac laptop though and we will continue to monitor other user's experiences. At this time I don't have any specific diagnostic you can run, but over time I hope to improve performance for all users with optimization.

Ok, I'll keep playing around with it and see if there is anything I can do on my side.

I have a windows PC but when I first started the game it took a very long time. But when I adjusted the settings it worked fine.

I can confirm a similar experience on my 2015 MBP. First time I tried creating a new game, it just stuck on the ...Loading game... screen. I had to force quit it and lowered all settings to a minimum before trying again.

+1

I may have to implement a check specifically for Mac hardware that will automatically lower the quality settings so that this is not the player's first experience when trying to start a new game. Obviously you would be free to experiment with settings after that, but this solution might ease the initial frustration of having to force quit on your first attempt at launching a new game. I'm genuinely not sure why it would hang the loading for such an extended time.

When reporting an error of any kind, especially a game crash, it is very useful to see the game log output file. The log file can be found in the "Lacuna Passage_Data" folder (which is alongside the exe) and is named "output_log.txt". On Mac it is located in "~/Library/Logs/Unity/Player.log". If your game crashes, do not relaunch the game immediately or it will overwrite the previous log file. Copy the file to a different location first and then upload it here as an attachment to your topic.

Under review

I updated all Mac builds to Universal builds which seems to have drastically decreased the likelihood of a crash, but I'll continue to look into performance enhancements in the future.