0
Under review

Reserve power shows negative number and will take power from suit instead of supply it.

wrongwayjerry 3 months ago in Gameplay • updated by Tyler Owen (Lead Developer) 2 months ago 8

I had gone to sleep and at some point the power had drained. When i woke up and checked the status the reserve power was showing a negative number. How can you use more electricity than what is available. The system was charging so the number was going back to zero. Finally, if you charge your suit when the number is negative it will remove power from your suit setting the habitat to zero.

Fixed

I had an incorrect limit check during sleeping. This should be fixed for 0.59 official release (you are playing on the public beta). Thanks.

Bug seems to be still there. I'm on 0.59.1 and the power went to -19.9%.

Under review

Was this also while sleeping?

I seem to recall I watched it slowly drop from -19.8 or so to -19.9 but I'm not sure. It might also be I watched it drop down from +10-ish and then went to sleep.


I tried to reproduce it but failed. All machines were on 'Not Producing' this time however, so it might be that they only bring power below 0 when they are producing on reserve power before you go to sleep.

If you experience this again after sleeping hold on to your save file so I can review it. I can probably pinpoint the problem without it, but that would be helpful. Thanks.

Fixed

Found another issue that can cause this bug and I believe that it has been fixed for the next update now as well. I might put this fix out before the next major update since it's a fairly significant bug.

I just confirmed it only happens for me if there are parts producing when you go to sleep. Interestingly, the opposite also seems true: I went to bed early (around 1300) with power at ~25% and when I woke up the next morning before sunrise, electricity was at 99%, as if it had been generating power all night. Does this fit the expected behaviour resulting from this second bug?

Under review

That seems like it would be a new issue. I'll look into it.