0
Fixed

Hab status panel may show state of previously visited Hab

Mr. Fusion 3 months ago in Gameplay • updated by Tyler Owen (Lead Developer) 3 months ago 3

When moving between habitats, the status display panel may show the system states of the previously exited Hab under certain circumstances, until the player interacts with the status consoles at which point the display gets updated to the correct states.


There appears to be some inconsistency in this: when I moved from a powered up Hab to an unpowered one, the display was correct (all red). When I moved back to the powered Hab, the panel of that Hab still showed all red even though everytjing was in fact running, until I used the status console there.

Actually, I'm not quite sure what the status panel shows when moving between habitats, but it is not correct.


I went from a fully functional Hab to a fully unpowered one, and the status panel in the unpowered one showed Electrical as green and the other 3 as yellow, even though if it had indeed showed the status from the one where I came from, all 4 should have been green (it was still daytime so none of the units should've been running on local power at that time).


However, I think when I entered this habitat the first time (several days ago) the 1x green 3x yellow was about right, so somehow it currently shows the state in which the previous hab was at the time of the previous visit to this hab...?

Under review

Thanks for the report. I'll try to get to the bottom of it. Right now I'm focused on revamping the control options in the game so it might be a few days before I can look into this.

Fixed

I believe I've found a simple fix for this, but I won't know without further testing if this fix covers all possible scenarios. Will be in next update.