0
Fixed

Black Screen on Habitat Exit

Bastion 3 years ago updated by Aaron MacDonald 2 years ago 17

I am consistently getting a bug upon attempting to exit the habitat for the first time - I have so far attempted this in five new games, and it has happened each time. Each attempt has been made after activating all the exterior modules and entering the habitat, and in two attempts I consumed food and water before attempting to leave while in the other three I did not. When trying to leave, I click on the outer door of the airlock, refill my suit's power and oxygen completely, and click confirm. The screen fades to black and says "Loading" for a few seconds, but then the text disappears and I am left with only the black screen. There is no unusual CPU or RAM usage visible in the Task Manager, and the game can be minimized with Alt+Tab without issue. Audio continues to play normally, but no sound cues suggest anything is happening when I press the WASD keys. I cannot bring up the in-game menu. On the fourth attempt, I left the game sitting on this screen for five minutes, just in case, but nothing changed. The only way I have found to exit the game once on the black screen is by minimizing it and closing it from the Taskbar or Task Manager.


I've attached my output log: output_log.txt

Fixed

There is a patch for this uploading right now. Sorry for the inconvenience. This only affected a certain percentage of players and was not caught before release.

Nice! What was the problem, if I may? I'm curious.

Player position was getting clamped to an incorrect location due to a script execution order bug which was preventing the exterior areas from loading correctly.

I did confirm, the patch fixed it for me! I am able to leave the habitat now.

Yay! Glad to hear it. Thanks for your help in describing the issue.

And thank you for making a cool game!

And does the patch also happen to fix the bug with being unable to sleep that I seem to be having? Or should I continue making a report for that?

Could you be more specific? Are you getting a message that you cannot sleep because you are still in your EVA suit or is it some other issue?

When I click on a bed, the PDA comes up with the option to change sleep duration. Clicking to confirm the time lowers the PDA, but leaves me standing and staring at the bed, unable to move the character or rotate the camera. It has happened the two times I tried to sleep - once with the default time, and once with reduced time - but I haven't experimented any further with it yet. I was going to create a separate post for the issue once I messed around a bit more and saved an output log from it. I'm downloading the update that just posted to Steam right now, so I can check it again once that finishes up.

Interesting. Yes please do post a new report for this. I'll want to try to recreate it.

This just happen to me today as well, Habitat Alpha and Bravo worked fine, however (On day 17 personal best!) I found  Gamma and it behaved just like Bastion said it did.

Under review

Do you have a save file in which you can reliably recreate the black screen? On PC, your save file can be found at C:\Users\[USERNAME]\AppData\LocalLow\Random Seed Games\Lacuna Passage\survivalsave.lps. On Mac it should be located at /Users/[USERNAME]/Library/Application Support/Random Seed Games/Lacuna Passage/survivalsave.lps.

i didn't sleep/save before I tried to leave. I will try to recreate the bug tonight. and update the post.   

Owen,

I reached gamma and saved, also I tested a few things. if i leave right away, everything works fine. If I eat or craft the screen is black when leaving.  here is the save file. My file structure was not the same as you posted. Please let me know if i uploaded the wrong file. Thank you.  

survivalmode.lpsave

Thanks. I'll take a look and hopefully have a fix soon.

Fixed

It looks like it was an issue with rovers. The system currently has the rovers floating above the ground when you are not near them or while you are in the habitat and then they drop with physics when you get close to them or leave the hab. This allows the legs to get in the proper position aligned with the ground every time. There was an issue with the wheels not "settling" properly which wasn't allowing you to leave the hab. I've adjusted this so that hopefully that won't be an issue in the next patch. 

Mr. Owen


Thank you for your feed back!