Datapad controls may get locked in some cases

Mr. Fusion 3 years ago updated by Tyler Owen (Lead Developer) 3 years ago 8

Datapad controls (arrow keys + enter) may get locked in an unresponsive state at times: the selection highlight is missing, but you can hear the sound made when moving it as you press the arrow keys, however, hitting Enter doesn't activate anything so it's not just a visibility issue. You have to hit Esc to dismiss the datapad, then bring it up again and then it'll work correctly.

I couldn't yet find a clear pattern or reproduction method, but three times it happened after a failed world object interaction (left click on something which then produces an error message): once when I tried to access a "buried container" cache without an excavation tool and thus getting a message telling me that, and twice when I tried to pick up a deployed solar panel with not enough inventory space, again with a message about it. Opening the datapad after these events had it in this "locked" state. However, unlocking it and then trying the previous interaction again did not trigger the issue a second time, so there seems to be some other factor to it too.

(My current hunch is that it happens only on the first such failed interaction per play session, and I have a test case in my playthrough which did it once, so I'll try to fiddle with it to see if I can get it to trigger on purpose by some combination of actions.)

Under review

Yeah, I'll have to see if we can find a way to replicate this issue reliably, otherwise I don't think I'll be able to pin down the bug.

I managed to figure out when does it happen. For testing, I had one of those "3 solar panel" locations to interact with, but it also happens when you try to use a "buried" cache location without an excavation tool.

To test with the solar panels location:

  1. Fill your inventory to capacity so that you can't pick up anything.
  2. Go to the test location.
  3. Open the Datapad, navigate to any screen except the Home screen, then put the Datapad away with "E'" while leaving the Datapad on that screen.
  4. Left click on the large solar panel, at which point you get a message that you don't have enough space in your inventory.
  5. Press "E" to open the Datapad.
  6. Note how the selection highlight is missing. Using the arrow keys or Enter produces the navigation/selection sound, but nothing actually happens. You can put the Datapad away with "E" and take it out again with "E", the condition persists.
  7. When the Datapad is open, hit Esc to dismiss it. You can already see how it jumps back to the Home screen and the selection highlight appears before the Datapad is lowered.
  8. Open the Datapad with "E" again and now it will function correctly.

You can repeat steps #3 to #8 to reproduce the issue by this process as many times as you want. Which screen you set the Datapad to doesn't matter as long as it's not the Home screen, the issue does not occur on that one.


Thank you so much for the thorough steps to recreate this. I should be able to fix this soon now that I can look for the failure point in your steps.

I replied to this in another thread as well. I am having a similar issue, but it's happening EVERY time I bring up the datapad, and NOTHING seems to be alleviating it. I've even exited the game and restarted a new sandbox game, and it still happens. So at least for me, whatever was causing it 4 months ago seems to have gotten worse.

The reply you got in the other thread explains how your issue differs slightly and I'm hoping that an update later today or early tomorrow should help you. Sorry you are having problems.


This issue was never correctly marked as fixed from a few months ago.

Regressions are such a pain... This issue is kind of back, with a little twist. Clicking on anything interactable which itself doesn't bring the Datapad up, such as power switches and maintenance panel doors locks Datapad controls if it was left on any other sceen than Home and reopened with the "E" key.

Eg.: press "V" to bring up Vitals, then press "V" or "E" to put it away. Click on a maintenance panel door, but do not interact with anything inside. At this point:

- If you press "E" to bring up the Datapad, it will be locked. Putting it away with "E" then bringing it up again with "E" multiple times doesn't change it, it remains locked.

- If you press any other Datapad screen hotkey, inlcuding "V", the Datapad will come up with the selected screen unlocked.

If you press "Esc" to dismiss the Datapad when locked, it jumps to the Home screen and unlocks.

Thanks. I believe I have this fixed again. I'll probably put out a patch with some other fixes soon.