0
Completed

Another Problem!

MarsWalker 3 years ago updated 3 years ago 13

I've just found a new hab and I got all modules up and running in good condition and they all have power turned on but my habitat says that electrical is offline and the hab has no power. I worked on all the modules and got them going by 12:00 so it was day light for quite a few hours. The hab never got power though and I was forced to turn around and go back to the closest hab because this hab wouldn't even let me eat. I'm down to 100 calories so I have to leave pronto. I have 73% oxygen left and 100 on the battery so I'm sure I'll make it unless I starve to death first. I don't understand. Shouldn't the hab gotten powered up while everything was up and running well during daylight?

Edit: Okay I made it but I was down to zero calories and dangerously fatigued. I thought she was going to have a heart attack by the time I got there. Thankfully it was fairly close to the one I had just found. Phew....I still don't get it though. Now that I'm not panicking anymore, I'm wondering if I should have given that hab my own battery power?

Under review

Hmm. Well if there were any solar panels connected to the electrical module and there were no other component failures with it then it should have started generating a charge for you. It should no longer require a reserve charge itself in order to begin charging the battery. You're certain that it didn't have any component failures and that the power switch was turned on?

Nothing, I double and tripled checked everything and also ran quite a few diagnostic tests because my life was on the line. I didn't overlook a thing.

Also, now, at the other hab I'm trying to fill up some oxygen tanks and I filled two of them when that whole plan just disappears. It's completely just, poof gone. I check in the data pad documents and it confirms it's gone. Do the plans only have a certain amount of jobs they can fulfill...because that doesn't make sense at all to me? A plan is just a plan. But it's gone. I can do a video of all this if you want although, I can't now show that I did possess that plan, lol.

The oxygen canister plan (temporarily) disappears from the list when the hab has less than 50L oxygen reserves left, since filling one canister requires at least that much.


Probably not the ideal solution (I believe it's on the "this should be improved in some way at some point" list), but this was the simplest fix the current crafting mechanism allowed without having to introduce some new UI element, crafting input category, feedback text or anything else.

Okay I've got the plan back now. I'd wondered, since I'd realized the hab was low on oxygen since I had stolen some of it before I went out on that jaunt and found that other hab, if it doesn't show when there's not enough oxygen to support filling the tanks. If so, I've never noticed that before, lol.

I wish now that I hadn't left some full oxygen tanks at my other hab which is too far away. Anyway, when I get enough oxygen tanks I'm going to go back and video what's going on over at that last hab.

Let me know if you need me to make the video and I'll do it later on tonight. I just went back and the hab's modules have been running since I left but there's still no power there. It shows electrical is functioning but everything else is in the red and there are no lights working either. I forgot to turn recording on dang it, but instead I just got a screenshot so I just quit there and will redo it later tonight if you want. Here's the screenshot I did get and the custom objective marker I'm heading towards is the hab in question. It's in the north west. Let me know if you'd like to see the video of the hab and I'll go back later on and make sure I record it this time.

If it's still behaving the way you describe then it would be even better if you could provide me with your save file so I could investigate myself. The instructions to access the save file are available on the home page of this forum.

Okay, will do. Do I have to go back there again first or no? I guess not.

I'm leaving for the weekend, so I'll have to check it when I get back next week, but this will let me load your save in the editor so I can inspect whatever value might be going funky. Thanks.

Okay, I'm good. I just went back there and did a little repairing on the electrical module, just the wires and fuses and then I went to activate the weather station near there and found some more caches near that with more oxygen, thankfully, lol. So I'm going to shut down that hab for now since I won't go back to it till you investigate it. I'll look for the fourth hab instead and see how that one is. Btw, is there another big update this weekend? I'm not sure if I read that somewhere or not. Anyway, thanks and have a good weekend and hopefully a little R&R :)

Started

Somehow your reserve battery charge at that location ended up in the negative. I've had that happen with battery values in the past and obviously I screwed up in preventing it completely. I'll get a fix out soon. The fix should actually reset the battery back to zero so that your current save would still function.

Completed

Fixed the issue and it will be in the next patch.

Okay, awesome. I started a new game anyway. I thought I had to since there was an update on Friday. No worries though, t's cool.