0
Fixed

Won't produce oxygen or water

PolaricEntropy 3 years ago updated by Tyler Owen (Lead Developer) 3 years ago 18

Hi!


Having a great time with the game, however I've run into an issue (twice in two separate games). My hab won't produce either oxygen or water, but the modules are online (and water says producing in the hab status screen but nothing is happening) and diagnostics of each also indicates they should be producing. Not sure if I'm just missing something or what is going on.

Under review

Is it possible that you don't have any working tanks installed for either module? If you are able to, it would be good to get a screenshot of both the Diagnostic screen for those modules and the Habitat Status screen so that I could try to see what is going on. Thanks.

Actually saving, exiting the game and then loading it again fixed it, glad to know at least that works so I can carry on with playing.

Never mind, seems to have broken again when I exited the module. Inside when I load the save it says it's producing oxygen and water (it's dark outside so power reserves are around 60% and dropping), it also states I have some 47L of oxygen and 0.2L of water (doesn't seem to increase though, or maybe it's just slow). When I exit the module all the stats on the module goes to zero and I get a message about not having enough power to charge my suit, oxygen is at 100% in my suit though.

Can I ask what version number you have in the upper left of the main menu?

V0.53p3. I've attached what I believe is my save.


output_log.txt


Lacuna Passage.zip

Started

Okay, I finally figured this out. It was a combination of a bug and probably a bit of poor design. Currently when you leave the hab it automatically tries to top off both your battery and your oxygen from the hab reserves. If there is not enough of either to completely refill your supplies then it will empty out the reserves. When you left the hab it emptied out both, which if done at night like you did, will leave the hab with no backup power to run all the life support modules, so everything shut off. However, there was also a mistake in the code causing you to only receive 1/100th of the amount of battery recharge you should get for your suit. So you emptied the reserve battery, but it did not appear like it actually recharged your suit battery. I've fixed the bug and will have a Steam update patch available soon. That being said, I think I will prioritize the creation of a new datapad screen that will come up when you attempt to leave the hab which will allow you to choose how much oxygen and battery you want to pull from reserves before leaving. This should prevent you from accidentally causing all your systems to go offline when you leave the hab at night.

Thanks!


Just out of curiosity, assuming you had 0% of both oxygen and energy in the suit when you attempt to leave the hab, how much does that drain a fully stocked hab with say one storage tank for the oxygen? I would imagine it won't take out all the electricity since the hab battery must obviously be quite a bit larger than the suit's. How much O2 does the suit hold?


Do you know of an ETA on the update? Like before the end of the week or next week? Want to continue to explore this marvel of yours ^^

Fixed

The fix should be live now. Replenishing a fully depleted suit battery will fully deplete the reserve battery, but that's something that I'm looking to balance. In fact, I would like to add the ability to expand the reserve battery capacity by installing additional battery units in the Electrical Module similar to installing additional tanks in the Water Reclaimer or Reoxygenator.

You're quick! Seems to be working nicely! :) I'll report back if I encounter any other issues.

Uhm, is it just me or did all WayPoint stations disappear? Was pretty sure I had one working earlier (fully repaired) and now it's gone. Tried using the map you had posted on Trello to spot other ones, but can't seem to find a single one of them. Could you check my save to see if they are just there and it's me being blind?

Perhaps it was a different save you were thinking of? There are 16 terrain tiles and many of those have two possible spawn locations which are randomized for each new game.

Well, in looking at the WayStats I did actually find another save bug that was causing them to get switched off, so I'll get that fix in soon too. Thanks so much for being active with reporting things. Let me know if you still seem to have them physically disappearing though.

Started a new game after I got p6, seems to be good now.

Not sure if this is a bug, but is it intentional that you can stock up on more stuff in you inventory than your maximum 50kg limit? Or is it some sort of impact of storing too much that I just haven't noticed?


Also does empty component slots degrade?

Good catch. This was actually intentional, but I think I need to revisit it. Once you go over 50 kg it starts impacting your movement speed up to a max of 75 kg at which point you can no longer run (I think). This was an early attempt at an encumbrance system that I never really fleshed out or explained, so I'll probably need to make some adjustments. But it's not exactly a bug.

I started a new game today and after getting all 4 systems working, went inside. Water was producing but always at negative amounts? -.7, then later it went up to -.4 but I was never able to get any O2 producing. I was thinking it was due to negative water. Bottles were being produced. I found this post and restarted the game a couple times. Then water was at 0 and finally started going up, as well as oxygen started being produced. I'm guessing the water being at negative caused no O2 from being generated. On the game restart where the water was not negative anymore, all 30 bottles were gone and it started making them again. 


What happened today seems similar to what is described here so I added to this instead of making a new post.

Hey there, I've converted your comment to its own bug report since this is something new I haven't seen before. Thanks for reporting and I'll try to update you when there is a fix.