0
Fixed

Multiple Bugs I Encountered in v0.53p3

Robert N. Adams 3 years ago updated by Tyler Owen (Lead Developer) 3 years ago 25

I encountered several bugs in a 9 hour play session a day or so ago. Here they are:


1. Upon sleeping/saving, the three WayStats surrounding Habitat Alpha went offline for no reason. I went to bed, woke up, and the icons were gone from the map. I walked to one of the WayStats from memory, turned it off and on again, and it worked just fine but nonetheless continued to not show up on the map. Any WayStats affected in this way remained this way for the remainder of the game and the issue persisted through restarts of the program.


2. After #1, I had icons move around on the map. Two white diamonds moved to the Northeast of the map (where I had yet to actually travel).


3. At Hab Beta, every Solar Panel Mount on the Water Reclaimer would bring up the RTG Mount instead when clicked on. The RTG Mount brought up something else instead (that I don't remember). The Solar Mounts were unfixable as a result.


4. At Hab Beta, I encountered a duplicate door. That is, the interior Hab door had two doors overlaid on one another. I had to open the door and then open another clipping through it to access the interior. Entering and exiting the Hab resolved the issue.


5. Crafting items did not properly consume resources in certain situations. For example, crafting a Filled Oxygen Canister would not properly delete the empty one. Later in the same game, it did. This happened with a few things and seemed random overall.


6. The pod you begin in does not show up on the map yet continues to show up on the scanner. This made navigation in the starting area confusing.


7. Occasionally, a container would show the wrong inventory. Opening up a Downed Satellite (that I had definitely never been to) instead opened up my Player Inventory. The label on satellite also said "Player Inventory" instead of "Supply Barrel" as it had in encounters with other similar units in the same play session.


8. I encountered the "Battery would not recharge" issue other players mentioned on here, but I also recall the dev saying that that issue has been solved so I'm not sure if it would apply here. I fixed it by restarting the game.


I have video of my entire play session (minus the opening bit as I forgot to turn the recorder on >_< ) & screenshots of some of these issues to hand. I haven't posted them online anywhere so as not to violate embargo, but I can provide them to the developer upon request. I also still have my save file and can provide that as well upon request.

Planned

Wow, looks like you got the luck of the draw when it comes to finding bugs! Most of these are pretty simple fixes so I'll try to get to them this morning. Thanks so much for the detailed report.


A couple things that could help me greatly in tracking these down though. Could you please tell me the map locations for the habitats you mention? They are randomized on each playthrough with a total of 9 possible spawn locations so I'll need to know which ones you were at in order to fix some of the incorrect assignments and such. Thanks.


I've shut my computer down for the moment to get some sleep, but I can probably get this to you later tonight. Unfortunately, since p5 deployed, exiting the Hab results in a black screen. How could I get you the coordinate information via the map?

From memory though, I do remember that Hab Alpha was in the bottom right, Beta was damn near in the middle, and Gamma was at the top left.

Started

Those rough positions are good enough. Thanks. If you are able to recreate the black screen reliably you should attach your save file here so that I can check that as well.

Okay, will do later. The ones in %appdata% etc. Random Seed Games, correct?

Correct. Just the survivalmode.lpsave is all I need really.

Okay, I think I managed to fix most of your issues except for the black screen and the duplicated door. I haven't been able to recreate them. The other fixes should be live on Steam in about 30 minutes.

Sorry, I got caught up in other things, but it should be live on Steam now.

survivalmode.lpsave


Here's my save file. Sorry for the wait, it's been a hectic night. I guess we've both been busy!


Yes, the Black Screen still persists. It goes ...LOADING... and then it goes to a black screen.

I failed to mention that for some reason, the hab lights are all off as well during the re-load. I apologize for leaving that out in my initial message.


As you have the save file in hand now, I'm going to start a new game and overwrite the old one. I've made a local backup in a zip file juuuust in case, so let me know if this doesn't work.

Edit: I should add as a reminder that I have video & images available, and the video includes the duplicate door issue at some point. I could dig through it, find you a timestamp, and provide you the link to the video file on my Google Drive via e-mail.

I will investigate the save file myself soon, but if I'm unable to replicate it can you try hitting escape and see if it resolves? I know previously there was an issue where the menu screen could be activated while loading which would make it seem like it was frozen, but really it was just paused and you couldn't see or interact with the menu. Escape would close the hidden menu and allow you to continue. I thought I fixed that, but it may be happening still. Just want to rule it out.


If you are willing to provide the video that would be extremely helpful as well. Thanks so much again for all your input here.

Sent you an e-mail with this stuff. o7

+1
Fixed

It looks to me like somehow the black screen overlay is just staying visible because the game is obviously doing things behind it if you can still hear sound effects triggering. I may have fixed the problem in the next update, but I also put in a workaround that automatically sets the overlay to disappear when you open the menu as long as it isn't currently loading. If you encounter it again you can just open the menu to make the black screen disappear hopefully, but I will have to do some more research to figure out why it would remain visible in the first place. I'll put out the update in a patch later today probably.

I got the black screen just now as well on p7. Was exiting the habitat while pressing Esc during the loading phase. It continued to load and no menu came up, I could still move with WSAD (there were movement sounds) and the screen went black. Couldn't get a menu up (tried Esc twice). Turned the game off via Alt + F4.


Edit: Turns out it happens even though I did not press Esc during loading. Seems to happen every time now when I try and exit. Didn't have this isue during my previous session on p7, so it's weird.


survivalmode.lpsave

Started

I was finally able to recreate the black screen bug with this save file so I should be able to track down the cause now and get a fix later. The fix should also apply retroactively to save files that are being affected by it so keep your save file and the patch should resolve it once it goes live. Thanks!

+1
Fixed

Okay, check to see if v0.53p8 has fixed the black screen issue for you.

Now it works. Had the distinct impression that I went to sleep in Hab Beta but woke up in Alpha when the bug happened, now I wake up in beta as I should and it's possible to leave the hab. Nice work! :)

Got another issue that I thought would be easiest to bring up here (since this is where the save is attached). Could you look at the WayPoint station at: Lat 283.01, Lon: -6.4391?


Every time I try and bring up the screen on it it brings up some random empty circuit board slot, and if you fill that slot the component literally disappears since you get a new empty slot if you try and bring it up again.

Found and fixed. I might wait to put out the patch until tomorrow though so I can include a few other fixes. Thanks.

I've been getting some of the same issues (before p6), glad they seem to have been fixed.

Tyler,


Bit of an update. I started a new game about an hour prior to this post. I encountered a couple more issues.


I got Habitat Alpha back online (situated in the Northeast of the map this time, Lat 283.0853 Long -6.4536). I walked Southwest because there was a WayStat directly in my line of sight. I repaired Fuse Slot 1, replaced the fuse, repaired the Circuit Board Slot, and brought the WayStat back online. I then proceeded to walk further Southwest.


Around a minute or so later, the game locked up entirely. I think what happened is I had the scanner up, brought up the map, and at that exact moment the next section of the map began loading and the screen hung up. I could still hear the game. I pressed E and could move the cursor around (heard the sounds), but the screen was completely static on the tablet.


I reloaded, repeated the process by accident (I think), and it happened again.


I'm not sure if it was toggling the scanner, switching the scanner off and bringing up the map, or just bringing up the map that did it. In any case, some combination of these things right around where the map loaded made the screen freeze up and go static.


Additionally, upon re-loading the second and third times, I encountered the bug where the habitat couldn't recharge my battery (despite being powered). I also encountered a different bug. I had an equipped (open) Portable Solar panel, but it wasn't recharging my battery. I had to Deploy (close) the Portable Solar Panel and Equip (open) it again to get it to work.


Here's the save file from the same in question. Heading out the Hab door and bringing the scanner up will show the WayStat slightly off to the left out of the door. You should encounter the power bug & Portable Solar Panel Bug.


survivalmode.lpsave

Good stuff. I'll look into this save file as well. Thanks again. You are helping make the game objectively better with these reports. And it seems you are enjoying what's there well enough to keep playing despite the bugs. At least I hope so and you're not just masochistic.

A bit same here, I'm in charge of QA in a modding team, so I know how things are and how difficult it can be to get rid of the issues. No experience of Unity though, but I bet it's a lot easier then Unreal Engine 1 :D

Little bit of Column A, little bit of Column B. Finding and replicating bugs is a challenge in its own weird way. I also used to do a fair bit of playtesting for other games so it's kind of a force of habit at this point. :V

+1

I tracked down the duplicated door issue and that fix will be in the next update.