+1
Fixed

[0.64p1] Loading indicator stuck on screen

Mr. Fusion 2 years ago updated by Tyler Owen (Lead Developer) 2 years ago 8

When leaving a habitat, the loading indicator gets stuck on the screen indefinitely, or rather, gets readded once the transition / loading phase is over. For a moment it disappears along with the loading hint, then reappers slightly below its previous position and stays there.


Whenm going back inside, it gets removed properly.

Under review

I think this has something to do with PRTs. Can you confirm for me if there is a PRT within roughly the area around the habitat?

Yes, it's parked right in front of the hab I'm exiting from, within view as the external airlock door opens.

Planned

I'm pretty sure it's related to the way that PRTs load in after exiting. It's a difficult issue that I thought I solved previously, but I'll revisit it.

Additionally, this condition appears to block running, and opening the menu screen with Esc (and with the Help and Menu buttons on the datapad), however Esc still dismisses the datapad. so it's not the key itself that is blocked.

I forgot to ask if you have a save file where I can test this. I know I've experienced it before also, but it's not 100% reliable. Part of it is a physics calculation for setting the wheels on the ground before the load is supposed to complete, but obviously something is going wrong in some cases.

Exiting from the hab in this save should do it (a PRT is right in front of the entrance), I tried a few times just to be sure and it happened each time without fail. stuck_load_indicator_save.zip

+1
Fixed

This save file helped me identify the issue. It should be fixed in the next update (next day or so).

 Also happens when loading into an emergency pop tent / remote base with a PRT parked nearby.  And not so nearby... maybe anywhere in the same chunk?


As Mr Fusion mentions, you can't get to the menu when "LOADING..." is displayed.  If you aren't near a hab and need to pause or exit, you must drive to a different chunk first.  Or Task Manager > kill the process -- I've had to do that a few times when I had to take a call.


A possible short term fix might be to allow the menu to be reached despite being in the LOADING... state.